News, Announcements, Feedback, Improvements, Changes and Policies.
#7022 by ThemeSplat
June 22nd, 2015, 3:13 pm
Upgrading to phpBB 3.1 will render previously installed MODifications (A.K.A MODs) and styles unusable.

phpBB 3.1 is not compatible with 3.0 and most of the previous files will need to be removed prior to upgrading to 3.1.
To upgrade, perform the following steps:

A- Preparation
  1. Backup all board files and the database.
  2. Download the full package.
  3. Unzip to your desktop and open the phpBB3 directory.
  4. Remove (delete) the config.php file, and the /images and /files directories from the package.
  5. In Administration Control Panel (ACP) > GENERAL > Board Configuration > Board settings
      Default style: prosilver
      Overide user style: Yes
  6. If spambot countermeasures are enabled: Administration Control Panel (ACP) > GENERAL > Board Configuration > Spambot countermeasure if the installed plugin used is not GD image, GD 3D image, Simple image, Q&A, or reCaptcha, then change it to one of those.

B- Clean-up
If you have more than a few MODs or otherwise want to remove old entries from the database:
  1. Download and uncompress the Support Toolkit
  2. Upload the stk directory from Support Toolkit package to the root of your board installation.
  3. In your browser go to http://www.example.com/yourforum/stk, login if necessary.
  4. Using the menus navigate to ADMIN TOOLS > Database Cleaner and run that tool.

C- File replacement
  1. Via FTP or SSH delete everything from your board installation on the server EXCEPT for the config.php file, and the /files, /images, and /store directories.
    1. You can also, optionally, delete the /store/mods directory, if it exists (it contains the MOD packages installed using AutoMOD).
  2. Via FTP or SSH upload the remaining files and directories (from step iii above) to the root of your board installation on the server overwriting the existing files.
  3. In your browser go to http://www.example.com/yourforum/install/database_update.php
  4. Let that run to completion.
  5. Via FTP or SSH delete the /install/ directory from the root of your board installation.
Notes
  • If you use languages other than the standard British English you will need to find new language packs, upload those to the board, and install those languages again: ACP > CUSTOMISE > Language Management > Language packs.
  • Only use a good FTP or SSH client, such as FileZilla, to transfer the files. (File transfer utilities provided in host control panels can cause problems.)
You now have a new up to date board containing all your users and posts.

Time to install your new Premium Shiny Theme FLATBOOTS

Common problems while updating
https://www.phpbb.com/community/viewtop ... &t=2269196

NOTE:
This is quite lengthy process and it is suggested only if you already have experience with phpBB and an update process. Make sure you also have enough time as you cannot just interrupt it and resume it later. I am Available as usual to perform the update for you if you prefer to avoid headaches. I will be charging depending on the board size and update type, migrations etc. Contact me via PM or email for a quote.
#9432 by kotarou
November 23rd, 2015, 10:43 am
Hi,

I'm migrating my forum to 3.1 and Currently I have some mods Like:

AutoMod
Tapatalk
Advertisement Manager

Do I have to uninstall them on 3.0 before upgrading to 3.1?

Today I use another theme, but after 3.1 migration I will use the BBOOTS theme that I bought.

On my Test environment the migration was Ok and the content and new theme was perfect, but the mods mentioned above displays error on the ACP Panel (Some of them have specific tabs).

Also, I would like to keep at Least Tapatalk and AutoMod. Are they compatible with BBOOTS?

Any advice?
#9436 by ThemeSplat
November 23rd, 2015, 4:21 pm
Hi kota and welcome aboard

follow the instruction here: viewtopic.php?f=17&t=1286 . Short answer yes you need to remove them and clean all up otherwise you are just asking for trouble with the migration. AutoMod was for 3.0, under 3.1 the MODs are now called extensions and there is a "Customise" tab where you'll find your extensions and settings. Also there is a great tool that is used to uplaod the extensions directly via ACP. That is : Upload Extension and TapTalk and Advertisement Manager are available as extensions so you will need to re-install it once the migration is successful . Also take a look at this: [How-to] Installing, Updating and Uninstalling extensions and FAQ and for the Premium extensions: Community Markeplace
#10649 by wind770
February 1st, 2016, 7:04 pm
I've attempted this a few times, and have yet to be able to complete it. I've been using the STK utility to clean the database, and about halfway through it starts asking about resetting particular modules and whatnot, and I do it, and then start getting database errors. This time it was relating to mchat.

Should I go through and *remove* all of my modules, prior to running STK? Should I select "Yes" to all questions in the STK? I know it's a broad question...
#10653 by Leinad4Mind
February 1st, 2016, 9:24 pm
You need to go here: https://www.phpbb.com/community/viewtop ... #p13859361

Download that .php and run it ;)

If you've 3.1.6, if you've 3.1.7-PL1, you need to edit the phpBB a quick search and replace (3.1.6 -> 3.1.7-pl1)

;)

Who is online

Users browsing this forum: Exabot [Bot] and 3 guests