Page 1 of 1

Compatibility with PHPBB 3.3

PostPosted:January 7th, 2020, 11:28 am
by jaumerrr
Hello,

PhpBB3 is out:
https://www.phpbb.com/community/viewtop ... &t=2534541

is BBOOTS compatible or we need to wait for an update?

Thanks.

Re: Compatibility with PHPBB 3.3

PostPosted:January 7th, 2020, 3:57 pm
by ThemeSplat
Yeah I noticed 3.3 is out LOL
Do not jump ship for the time being. (see below)
ThemeSplat wrote:

Guys, you should know know the drill by now. No need to update right away. Give it a few months and keep an eye on the main phpBB topic for bugs.
In any case, in a few days the premium styles and extensions that needed an adjustment for phpBB 3.3 will be released…
What I always suggest is, create a clone of your forum in a sub-directory on your server and test things out for a few months before making a switch.


and:
Dion wrote:

This is an almost-complete excerpt of a post I made on one of my product support boards:

phpBB 3.2.9 and 3.3 will both likely be released in the very near future. phpBB 3.3 includes support for PHP 7.3 and Argon2id password hashes. phpBB 3.2.9 fixes a large number of problems with previous versions and adds some minor enhancements. Both contain changes that require an update to BridgeDD PRO, and I have released a minor update (2.3.9) that supports both.

One of the new releases of phpBB is a worthwhile update. The other is not.

After doing extensive testing on both, please do not update to phpBB 3.3 at this time. It has a serious issue in its Argon2id password hashing driver that could result in unusable passwords if/when you update PHP beyond the 7.3 branch. And despite assurances to developers to the contrary, phpBB 3.3 breaks a number of extensions and themes. I had recommended staying with phpBB 3.1 until a stable version of 3.2 was released; this situation is no different.

phpBB 3.2.9, on the other hand, appears to be among the cleanest phpBB updates in quite a while. Unfortunately, due to phpBB continuing a bad trend of leaving out enhancements to force updates to a new branch, it does not include the minor code changes required to support PHP 7.3 or Argon2id password hashing.

Dion Designs to the rescue!

At the end of this post is an attachment containing a ZIP archive. If you un-ZIP the archive and copy the four directories to the root directory of your phpBB 3.2.7 - 3.2.9 installation, you will have support for both PHP 7.3 and Argon2id passwords! The Argon2id password driver is much better than the one in phpBB 3.3 – not only is it immune to the issue I mentioned above, it also works with PHP 7.2!

Please be aware that you must copy the four directories every time after you update the phpBB 3.2 files to a new version, but before you run the installer to update the phpBB 3.2 database.

I will continue to test future phpBB 3.3 updates, and will let everyone know when the 3.3 branch becomes a worthwhile update. In the meantime, if you are considering updating your version of phpBB, please update to 3.2.9 and not to 3.3.

The ZIP archive is attached below.

fix32.zip

Re: Compatibility with PHPBB 3.3

PostPosted:January 9th, 2020, 4:12 pm
by iamART
Wish I read this before installing the latest. Going to have to reinstall everything from scratch and find a older version of phpbb.

Re: Compatibility with PHPBB 3.3

PostPosted:January 25th, 2020, 6:20 pm
by ThemeSplat

Re: Compatibility with PHPBB 3.3

PostPosted:January 26th, 2020, 8:58 am
by Bez
Thanks for the heads up Dave. :plus1:

But i doubt i will be going anywhere near that version anytime soon. :poo:

Re: Compatibility with PHPBB 3.3

PostPosted:March 17th, 2020, 5:37 pm
by Raykai
is it now safe to update to phpbb 3.3.0 ?

Re: Compatibility with PHPBB 3.3

PostPosted:March 17th, 2020, 6:21 pm
by ThemeSplat
don’t bother just yet ;) - No need to at the moment really…

Re: Compatibility with PHPBB 3.3

PostPosted:March 17th, 2020, 6:52 pm
by Raykai
ThemeSplat wrote:

don’t bother just yet ;) - No need to at the moment really…

ok so il stay on phpbb v3.2.8 until you say we should update.