The Special SiteSplat Membership has launched! Check our In Da Club Plan 👌
  • phpBB - How to Upgrade from 3.2.x to 3.3.x
  • News, Announcements, Feedback, Improvements, Changes and Policies.
News, Announcements, Feedback, Improvements, Changes and Policies.
 #32784  by ThemeSplat
 April 2nd, 2020, 3:04 pm
phpBB 3.3 should be backwards compatible with 3.2, however some extensions and custom edits may no longer work. The easiest upgrade method is to remove all existing files prior to upgrading and re-applying custom changes after verifying their correctness.

To upgrade, perform the following steps:
Ensure that your server meets the requirements for running phpBB 3.3:
https://www.phpbb.com/support/docs/en/3 ... uirements/
  1. Make a backup of the original files
  2. Make a backup of the database
  3. Deactivate all styles except for prosilver
  4. Deactivate any extensions which are not compatible with phpBB 3.3. Check with the extension author to find out if an extension is compatible or not.
  5. Set British English as the only language pack
  6. Download the phpBB 3.3 Full Package archive
  7. Extract the contents of the archive to your computer and open the phpBB3 directory
  8. Delete the following files from the package:
    • The config.php file
    • The images/ directory
    • The files/ directory
    • The store/ directory
  9. On your website, delete all files from your board EXCEPT for:
    • The config.php file
    • The ext/ directory
    • The images/ directory
    • The files/ directory
    • The store/ directory
  10. Upload the contents of the phpBB3 directory from your computer to your forum’s directory. You may be prompted to overwrite the remaining files. (If prompted to merge or overwrite directories, choose to merge them.)
Update the database:
NOTE:For large boards, you may wish to update via the command line interface (CLI) instead of using a web browser. From your board’s root, execute the following command:
php ./bin/phpbbcli.php db:migrate --safe-mode
(CLI Docs: https://area51.phpbb.com/docs/dev/3.2.x/cli/index.html)
  1. Using your web browser, visit install/ in your board’s root. (e.g. http://www.example.com/yourforum/install)
  2. Click the Update tab
  3. Click the Update button
  4. Select “Update database only” and click Submit
  5. Wait for the progress bar to reach 100% and for a message indicating that the update has completed
  6. Delete the install/ directory

Other important tasks:
  1. Update your language pack
  2. Update your premium style
  3. Update your extensions
  4. Running HTTPS?(you should!) Make sure you install BBssl to set your board correctly marketplace.php?mode=view&item_id=73
  5. Wanting your forum to run super faster, have total control with a modern setup and also save money by running your own cloud hosting? Send me a PM inquiring about a custom server setup.
  6. Using CloudFlare? Install this ext: marketplace.php?mode=view&item_id=48
Only use a good FTP or SSH client, such as FileZilla, to transfer the files. (File transfer utilities provided in host control panels can cause problems.)

NOTES and TIPS:
-You can easily update your premium styles directly via ACP in 1 click with the BBCore auto-update:
viewtopic.php?f=17&t=5012
-When uploading the 3.3 files to your server, do NOT overwrite your config.php.
-When backing up your files, ensure that your FTP client is in binary mode or transfers files without extensions in binary mode.
-Ensure that the root level .htaccess file is included in the upload. Some FTP clients do not show files whose names start with a period and you may need to enable the display of hidden files.
 #33041  by thepostman
 April 19th, 2020, 12:08 pm
Has anybody done this and if so did they have issues? I performed the upgrade last night and now I can not access my forum while logged in which means I can’t access ACP to set everything back up. When I am logged out I’m able go navigate go all the pages but once I log in I get a 500 error and can no longer navigate any page in the forum. I have reached out to our service provider and am still waiting on response.

Any insight you all could provide would be awesome!
 #33042  by WelshPaul
 April 19th, 2020, 12:45 pm
Hi, BBCore and FLATBOOTS are 3.3.x compatible and I believe so are all of sitesplat extensions but you need to confirm that any third party extensions are too prior to upgrading. What do your server logs say? The answer to your issue will be there! Also, phpBB has a few requirements which must be met before you are able to install and use it. Did you confirm that your server meets these? https://www.phpbb.com/support/docs/en/3.3/ug/

Unfortunately all we can do is guess as an “I get an error 500″ question provides no clues! Oh, and always take a full backup prior to updating so that if anything goes wrong you can simply roll back within minutes.
 #33048  by ThemeSplat
 April 19th, 2020, 6:02 pm
check your error log and then go from there.
 #33158  by Bez
 April 26th, 2020, 8:42 am
@ThemeSplat
Just a quick question, you advised in an earlier post to hold off updating to 3.3 now that you have posted this do you advise updating from 3.2.9 to 3.3.0 or just wait for 3.2.10.

And why do we now have 2 different versions at the same time? :whata:
 #33159  by WelshPaul
 April 26th, 2020, 12:32 pm
My 3.2.9 has many of the 3.2.10 fixes already applied and it’s a good stable build. I don’t plan on upgrading to 3.3 until at least 3.3.2 or later at which point I also plan on moving from php 7.2.27 to php 7.4.x.
 #33160  by ThemeSplat
 April 26th, 2020, 2:40 pm
@Bez, yup I would wait for 3.3.1 or 3.3.2…
 #33169  by Bez
 April 26th, 2020, 6:59 pm
Thanks guys. :plus1:
 #33183  by londoncyclegirl
 April 29th, 2020, 9:13 pm
I’ve just updated the PhPbb and all the extensions yet I’m still getting an error message :
phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.

Exception: The file “/home/*******/public_html/live/ext/sitesplat/flatbootsminicms/config/services.yml” does not contain valid YAML: The reserved indicator “@” cannot start a plain scalar; you need to quote the scalar at line 8 (near “- @dbal.conn”).

Any ideas please?
 #33184  by ThemeSplat
 April 29th, 2020, 10:25 pm
Hi Lon,
I think you forgot point #3 under “Other important tasks” :)

Also see this once done:
viewtopic.php?p=32740#p32740

PRENEXT_POST_NAVIGATION